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Bachelor-Project Task

Power Meter for 7-Tesla MRI Power Amplifier

In a research project, the department develops a high pulse-power amplifier for a 7-Tesla Magnetic
Resonance imaging (MRI) system. The power amplifier employs a high pulse-power final stage with
a maximum of 1 kW output power into a 50 Ohm load at an operating frequency of 298MHz.
Measurement of the power level and the amplitude envelope of the pulses is required during the
assembly and matching optimization of the amplifier units.

The task is to design, build and test a power meter circuit on the basis of an envelope detector
(integrated circuit log-amplifier AD8307) which provides a dc output voltage proportional to the
logarithm of the input power level with a slope of 25mV per dB of RF input power. The input signal
must be in the order of milliwatts so that only a sample of the 1 kW -pulse is to be fed to the IC. The
main part of the power has to be absorbed in a 50 Ohm-load resistor which sits on a heat sink while
a resistor-probe is used to take a sample of the high-power signal. The detector output voltage for
our MRI power amplifier signals will show a pulsed dc level which is shifted by a bias voltage. In
order to allow correct measurement of the pulse power level, the offset voltage has to be stripped
off before applying the measurement. Measurement can be afforded by buffering the detector
voltage and connecting it through a coaxial cable to an oscilloscope which will show the pulse
envelope. As a built-in meter, an LCD voltage display module (e.g., Voltcraft DVM210) is to be
included. This will require a sample & hold circuit (e.g., LF198) which is triggered by the TTL-pulse
from the power amplifier control circuit (the so called “Un-blank” signal). When the sampling of the
detector voltage is performed from shortly after the start of the power pulse to the end of the pulse
duration, the voltage display can indicate correctly the instantaneous power level of the pulse.

In particular, the task entails the following steps:

e Design a circuit for the RF load, probe and the AD8307 plus the operational amplifiers
required to cancel offset and as S/H-amplifier, buffer and scaling circuits for the output
voltages. Examples for various parts of the circuit are available from other projects and from
manufacturer data sheets. Design a circuit to provide variable delay to the trigger voltage
allowing to move the sampling instance along the pulse duration of up to 5 msec.

e Design a PCB using EAGLE software

e Assemble the circuit after production of the PCB at our workshop.

e Test the circuit regarding impedance match, insertion loss of the probe and the output
voltage of the IC; the circuit should function over 10 MHz to 500MHz but should be
Optimum at 298MHz.

e Adjust the output voltage of the circuit and set the LCD voltage display module such that at
1kW pulse power the display shows a numerical value of 60.0, representing 60 dBm power.
This can be adjusted using low-power signals from a test generator with precise output

levels in the milliwatts range.



Compare the results of the power meter display with measurements using an oscilloscope.
Verify the proper functioning of the circuits using a signal from a high-power amplifier with
CW- and pulsed excitation.

At the end of the work, a public presentation of results is to be given.
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1. Requirements Analysis

A power meter needs to be designed with following requirements:

® Input pulsed RF signal with maximum power 1kW.
® OQutput the power numerical value with the unit dBm.
® System should be optimum at 300MHz

RF signal

A

Square Pulses
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Input Signal
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Fig.1 Input signal

® Chip AD8307 and LF398 should be used in the circuit for signal conversion and sampling.
® |LCD module DVM210 should be used for the result display.

The power meter is feed with the pulsed RF signal, after process the power value of the signal should
be displayed on the LCD.

Input signal Output power

I PN [rosser
HHOED =

LF358 LCD Module
300MHz

Fig.2 System flow



2. System kernel model construction

Before the circuit design, the system model should be built. The model consists of four parts and
is shown as follow:

Attenuator AP AD8307 LM358 LF398

Pin | | TP1 P2 TP3 LCD

Q ? e | e Q

Fig.3 System model

2.1 Power attenuator
The input of the attenuator is the system input Pin.
The output of the attenuator is the test point TP1.
The value of attenuator coefficient is AP. The theoretic value is 60dB.
TP1 = P;,, — AP (1)

2.2 Chip AD8307
The function of AD8307 is transferring the power difference to a small voltage level. The transfer
factor is 25mV/dB.

If there is no input, the chip has a small output voltage Uo. The result of Ug measuring is about
0.2V. In real condition, the low part of the output curve is not linear.

The power difference is the subtraction of input power and initial power Po. The initial power Po
can be found in the data sheet. (Po=-80dBm)

The output of the chip is TP2.

TP2 =Uy+ (TP1—P,) - 25mV/dB (2)
With (1),

TP2 =Uy + [(P;, — AP) — Py] - 25mV/dB (3)
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Fig.4 Input / Output curve of AD8307

2.3 Operational Amplifier LM358
The function of Op Amp is transferring the AD8307 output voltage value to the final power value
in voltage form. This function controlled by a group fix value resistor and a variable resistor.
The formula form of the circuit function is as following:

(Uy = U2) * Rratio (4)

The output value of this part is TP3.
The calculation actually is the inverted of the formula (3). TP3 equals to Pin.

__ (TP2-Uy)

TP3 = Py =<2+ Py + AP (5)

In order to fit the form of (4), formula (5) should be reformed as follow:

TP2—-Uy+25mV*Py+25mV+*AP (6)

TP3 =
25mv

In formula (5) and (6), Poand AP no longer have the meaning of power. They become the voltage
level. Only the magnitude equals to the value of the power.

2.4 Sample chip LF398
The sample chip LF398 gets the value of TP3 and outputs to the LCD module.



3. Implement of modules
Based on the system model, the respective circuit of modules can be designed.
3.1 Attenuator

From the datasheet of the AD8307, the max linear input power is about 10dbm. But for real
requirement, the maximal input signal is 1kV. Thus an attenuation circuit is necessary.

A. Base circuit
The m-circuit is applied here.

Fig.5 m-circuit networks

Rz is a power resistor which value is 50Q, 50W. This resistor used to absorb the power from
input.

Rsis a matched resistor for AD8307 and value is about 52Q.

Value of R1 needs to be estimated.

Vinput = 1000V, the equivalent voltage value of 10dbm is 1V.

Rz, Rs full fill the relationship of voltage divider.

Ry 1V
Rz+Ry 1000V

= R, = 50kQ (7)
The base circuit is determined here.
B. High frequencies behaviors

The input signal will be 300MHz. Thus the value of resistor of Rz, R3 will be change.
The compensation should be applied in the circuit.

The SMD resistor will be used in real circuit. A simple model is built to analysis the condition in
High frequencies.



SMD 0805
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Fig.6 the SMD resistor
The size of SMD [=2mm, h=0.5mm w=1.2mm. The permittivity of material € is about 10.
The resistor is treated as a parallel plant capacitor. The capacitance value could be estimated

by formula:

h
C, = soerT (8)
The result Cp is about 0.03pF.
Then the software Qucs is applied to simulate the condition of Ry, R3 parallel with C, in 300MHz.

a) The value change of R>=50kQ in High Frequencies.

ac simulation 1':1"

AC1 . . .. C=003pF .
_ Vin

Type=ln. . . . . . A= - p—

Start=10kHz . . . . .. .. T

Stop=1GHz . . . . A - 3 A

Points=50000. " R=50k Ohm_

SRR @) =tma

-|Eguaticn : .

"Egnt -

“fm=mag(Vin.v) -

Fig.7a. HF simulation of R;
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Fig.7b HF simulation of R

From simulation, the Impedance of R1 will decrease in 300MHz, the value becomes to 16.67kQ.
Thus the ratio of the voltage divider will be change.

b) The compensation capacitor value estimated by simulator.
The complete attenuation circuit is built to find the proper value of compensation capacitor.

|ac simutation| [ e

N e

e ... .| . . Resokomm
op=1GHz 1

“Points=t0000 © - [ - - [

=" @)u=1000v - []R:500hm- A== T []R:500hm-

- Type=lin -

- Param=Cp -

- Start=0pF -

- Stop=50 pF -

. Points=6 .

Fig.8a Simulation of compensation capacitor
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Fig.8b Result of simulation with compensation capacitor

3.2 Analog signal conversion
After attenuator, the signal is processed by chip AD8307. Then a convert circuit which can
transfer the output voltage of AD8307 in to the final result in numerical needs to be design. The
operation amplifier LM358 is used to achieve the purpose.

The circuit is shown as follow:

The value is between 20pF to 50pF. In real circuit, a variable capacitor will be used to get a proper
value.
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Fig.9 Analog signal convert circuit



U1A is the one of amplifier units in the LM358. It is used as the voltage follower.

U1B is the second amplifier units of the LM 358. It is used as a differential circuit to transfer the
output of AD8307 to the final result. (The DVM module has the range -200mv to +200mv.)

In the circuit, R2 = R5 and R3 = R4.
R5/R4 = 25, this value is same with the output characteristic of the AD8307, which output slope
is 25mV/dBm.

Then the output of U1B (pin7) can be calculated by follow equation:

R
Upin7 = (Upins - Upin6)R_: (9)

This equation is match with the equation (4) in the system model. Upins is the output of U1A,
actually is the output of the AD8307. Uyins is the reference potential. Based on the system model,
this value can be applied for calibration and zero point adjustment.

KEYSIGHT |

Fig.10 the output example
Fig.10 shows the example in real circuit. The red line is the output in the test point. Left picture
is the output of AD8307. With the processing of convert circuit, the output curve is shifted and
compressed into the form in the right picture.

3.3 Sample with the TTL signal
After processing by convert circuit, the voltages cannot be displayed on the DVM module. The
result should be sampled

Basic Sample circuit
According to the specifications of the LF398, when pin8 is given a high voltage TTL signal which

is greater than 5V, the chip works under “sample state”, the output will follow the input.

The hold capacitor C5 will keep the sample value in a short time after the pin8 switch back to
ov.

Then the sample value will fall down to a very low (negative) power level.



Fig.11 Basic sample circuit

Between the output of LF398 and DVM, there is so-called “precision rectifier” circuit. The
function is similar as a diode, which can keep the circuit above 0 voltage level. It consists of
an amplifier and a diode. One unit of LM358 is used to implement this function.

Sample wide adjustable circuit

The basic sample circuit only work with fixed width TTL signal. In order to get different
section of the output curve. The width of TTL signal should be variable and adjustable.

The 555 Timer will be used to change the width of the TTL signal.

Basic function of chip NE555
The 555 Timer has many different work mod. Here, only the mono stable operation will be
discuss. The circuit and the waveform shown in follow:

A IN

ouT

Ik

|ty |

Fig.12 The mono stable circuit and waveform of 555



In circuit the pin 2 is feed the control TTL signal, every time when the TTL falling to 1/3 of
its full high, the output will be trigged and creates a high level pulse signal. The duration of
the output pulse is controlled by Ra and Ca.

tw = 1.1R,C, (10)

The 555 has a minimal response time tim= 10us when the input signal reaches the trigger
point.

The circuit should be modified to fit the design goal. The output duration time should be
variable.

The phase of output should be same with input TTL signal.

The improved circuit
The improved circuits shown as follow:

It

Fig.13 The improved circuit

For the variable duration, a variable resistor R1 added to the circuit. The max value of the
resistor is the 1M ohm. The capacitor C, uses the fix value of 10nF.
Thus the min and max duration can be calculated.
twmin = 1.1R,C, = 1kQ X 10nF = 1 X 10~5s (11)
twmax = 1.1R;C, = 10MQ X 10nF = 0.1s (12)

For the phase synchronous, a proximate method is attempted.
The RC differential circuit is used as the peak detector. Rz and C; are added in the circuit.

RC peak detector checks the rising of the input TTL signal, and transforms the wave form
rectangle to very sharp pulse (result in CP point). The Fig.14 shows the process.

10
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| tw

Fig.14 Work flow of circuit

Then the chip 555 receives the sharp pulse and trigged at the falling position. It produces
the output waveform which has nearly same phase with the input TTL circuit.

The minimal duration tq of sharp pulse should as small as possible in theory. The capacitor
Cz in RC differential circuit uses fix value 10nF and the proper value of Rz is about 3kQ after
testin Lab.
Thus the small time delay tq before 555 trigged can be estimated.

ty = R3C, = 3kQ X 10nF = 3 x 107 °s (13)

These also the real waveform in test and show in follow:
RIGOL ™0 H 1o0us :

Horimomal

Fig.15 Use RC circuit as peak detector
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Fig.15 shows the RC circuit produces a sharp pulse (red) at the rising of TLL signal (yellow).
At this time, the 555 produce the output with Ra in minimal value.

The next picture shows that 555 produce the output with Ra in greater value. Left is Ra in
minimal value and right is Ra in greater value.

1

Fig.16 Different output with changing the Ra

3.4 main board circuit
4 units above constitute the main board.

1) - 2) .
B I 1 _
1 1 ]
x
3 R | b
o= T
b a .
il 1 I =0
€1 1 T
3) 7 — = =
X 1
3 i l i RS L D
! I ¥
T = :': :l il
4 T )

Figl7. Main module circuit
1) High frequencies unit (AD8307).
2) Zero point adjusting and signal transform (LM358).

3) TTL processing (NE555).
4) Sample and hold (LF398 and LM358).
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3.5 Power module

In system, every chip has different power supply requirement. Thus an individual power supply

circuit is necessary.

Requirement of system (data from datasheet)

Chips Number Voltage /V
LM358 2 pics 1.5 to 16
LF398 1 pic 35 to 18
NES55 1 pic 45 to 16
AD8307 1 pic 27 to 55
DVM (LCD)" 1 pic 9V

The DVM should use the individual power supply. An individual 9V battery is used for DVM in

real circuit.

The Vmin = 4.5V and Vmax = 5.5V of the power supply were restricted by chips NE555 and AD8307.
Based data above, new power supply design as below:

[ s
| 1]
|

[ 1
| 1]

[ [yid
| ]
i

Two 9V batteries are applied as main power. In order to get the +5V voltage, the voltage

[ 1
| 1]

Fig.18 power supply

regulator chip 78L05 and 79L05 are used.

3.6 LCD module

According the datasheet of DVM, the module has “Hold” and background light function.

At backside of the DVM, there are 2 columns 10 pins interface.

13




Fig.19 Backside of DVM

Pin 1, 2 are measurement probe.

Pin 3, 4 are 9V power input.

Pin 5, 6 If connected, the background light will be lighted up. The jump pin CN2 (pin9, 10) should
be connected.

If Pin7 connects to Pin3, the figures shown on the DVM will be “Hold”.

Based on the info above, the simple circuit designed to implement these functions.

1.CD CONN
[TN_HD—=p-1 P-2p=—IN_L O]
» -3 Pyt
4 5 ——————=p-5 P -
[
3 -
- e p-7 P-gm—
= 7 L p-5 P16
— OH — .
o i a5 HoLO =
T
=| 3 —
5 T
—
4 I
RL
% 31,*__J.1_ - - — — Eg
Lil ~ 1705 o
LIGHT" o =
R
o I
o N N
GND GHD GND

Fig.20 DVM circuit
In the circuit, between Pin 7 and Pin 3, a button is set to run the Hold function.

Between Pin 5 and Pin 6, there is a simple time delay circuit. After man release the button, the
background light will keep about 3 seconds then go out gradually.

The basic principle of this time delay circuit.
Transistor T1 play a role of switch. When the button is push down, all the circuit turns on.
The capacitor is charged in a short time and the background light begins work. After the

14



button release, the capacitor discharge in a long time. Current go on flowing to T1 and keep
T1 working till the discharge finish. Then T1 turns off, therefore the background light loop is
also cut off.

The different capacitor value can be change to get different delay time. Here the 2200uF is
used.

4. PCB design

The software EAGLE is applied to design the PCB for 3 modules.

4.1 Software configuration

After setup the software, the component library should be added.

Extra library can be downloaded from follow website:
https://www.element14.com/community/community/cadsoft eagle/eagle cad libraries
+ Vishay

+ Texas Instruments

+ ST Microelectronics

+ Analog Devices

+ Linear Technology

https://github.com/rodan/Simplex-Eagle-Libraries
https://github.com/sparkfun/SparkFun-Eagle-Libraries

Decompress the download file, copy the “.lbr” files to the EAGLE installed path /lbr folder.

4.2 Basic step of PCB design with EAGLE
A. Draw the circuit schematic
1) From the menu “File” -> “New”->"Schematic”, open a new schematic design window.

B Control Panel - EAGLE 750 Proleesiong

File | View Options Window Help

New Y | € Project AGLE -
— d.
g Open "B schemat
. chematic ; :
Open recent projects » Graphical Layout Editor L
& Board 1 r
B Eoar for Windows (54 bit) 1Bsic
Save all ln Library
=1onal Editien . W

Close project

@ CAM Job ) 1zzmo e
- i) 19BE-2015 CadScf
Exit Alt+X vemvrred morlimide
™ up
Single , {E-LSE-YIM-1EL i
—————— @ Script
= Text

Fig.21 New Schematic window

2) Grid setting. From menu “View”->"Grid”, open the “Grid” setting windows. Usually the grid
display sets to “on”, size sets to 50mil.
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https://www.element14.com/community/community/cadsoft_eagle/eagle_cad_
https://github.com/rodan/Simplex-Eagle-Libraries
https://github.com/sparkfun/SparkFun-Eagle-Libraries

@ Grid 2

Display Style

@ On ) Off ) Dats @ Lines
Multiple: 1
Hint: It' = strongly recommended to uze the default

grid in =chematics.

Co ) Comea )

Fig.22 Grid setting

3) Add components to draw the circuit schematic. From menu “Edit”->"Add”, open the “Add”
windows. Input the key word to find the component, add it to the work area. In this window,
the package info of the component also is shown.

™ L‘
Name Description
4 adafruit
> 7555 TIMER R
4 linear Linear Devices & | O
> *555 TIMER s | s
4 SparkFun-AnalogIC Sparkfun Electronics' preferred foct prints - O O
> NE555 General purpose bipolar Timer . o o
4 ST Microelctronics_By_element... Developed by elementld : =
NESSSDT General-purpose single bipalar timers 1 0 o
NESS5N General-purpase single bipolar timers — —_—
4 stmicroelectronics ST Microelectronics Devices
NESSS General purpose bipolar Timer
4 Texas Instruments_By_element... Developed by elementld : =
NESS5D PRECISION TIMER e
NE555DR PRECISION TIMERS PRECISTON TINERS
DESS5EY EREGSTOMENMERS Package: DIPZ54PTB2YS08-8
fl
N Attribite  Value
MPN NES55P
OC_FARNELL 9589899
OC_NEWARK 60K6706
PACKAGE  PDIP-8
SUPPLIER  Texas Instruments
Fads Smds Description Prewiew
Search B> nessse -
Attributes BB -
o

Fig.23 Add component

4) Commonly used draw tools
These tools can be found on the left side of the window or in the menu “Edit” and “Draw”

Icon functions

€ | Show the component detail information. In the menu “View” -> “ Info”

16



“.* | Move the components.

. Rotate components.

# | Change the graphic attribute of the component. E.g. Align, Fonts, Size, and Layer etc.

@l | Delete component.

= | Component Name setting

Component Value setting

1 | “Smash” Separate the Name/Value from component symbol

/ Draw the connection wire

T | Add text to the symbol

T Add junction to the wire cross

8 | Add label to the connection wire

5) When finish the schematic drawing, do the electric rule check (ERC). From menu “Tool”->
“ERC”. After checking a window will show the check result and detail error information.

B. Design the board
1) The circuit schematic should transform to the board design. From the menu “File”->"Switch
to board”. The board window is opened. All the components lie on the side of work area.
The components are connected with yellow line which is called “air wire”.

E:] 1 Schematic - PRI ;j 2 Board - PAb3\PM_power_ml.brd - EA

Edit Draw View Tools L

tHe@ 2 i MR S

MNew Ctrl+N l‘(
(+ Open... Ctrl+0O
]
0
| |

Open recent

R Save Ctrl+5

Save as..

Save all

Print setup...
=y Print... Ctrl+P
@' CAM Processar...

s Switch to board

Import 4




Fig.24 Switch to the board mod
Point to attention: Do not close the schematic window, both windows are binding and if
the design changes in schematic, the board window will also change respectively.

2) Dragthe components to the proper position in the board rectangle (gray line rectangle) on

the work area. After laying the components, the tool ”Ratsnest”(-"-') can arrange the air

wire again to fit the new position.

3) Define the “net classes”, From the menu “Edit”->”Net classes...”, open the “Net classes”
window and fill with proper values for the line width, drill and tolerance. The different line
type also can be defined here. This function will be used later.

B Hame Width Irill Clearance
@0 default 20mil Omil 20mil

1 Omil Omil Omil

2 Omil Omil Omil

Fig.25 Net classes define

4) Define the “Design Rule Check (DRC)”. DRC is the layout rule. From menu “Tools”->"DRC”,
open the DRC define window. Set the proper value for the PCB element attribute.

= DRC (default) x

File | Layers | Clewrance | Distance | Sizes | Restring | Shapes | Supply | Masks | Mise |

EAGLE Design Rules

The defsult Design Rules have been set to cover a wide range of spplications. Yowr particular design may have different
requirements, so please make the mecessary adjustments and save yowr customized design rules under = new name

Edit Deseription. ..
[ neree into current settings

[ chesk | [ selest || camea ][ mmr |

Fig.26 Design Rule Check

5) Use the “Autorouter” tool to draw the wire on the board. From menu
“Tools”->"Autorouter”, open the “Autorouter” window. Select the wire direction on the
left and grid dependency rule on the right. Then the software can give a layout solution for
the circuit schematic.

18



;] Autorouter Main Setup 29

Preferred Directions The Autoronter iz routing the board with different
sets of parameters depending on the Effort

1 Top - T | 9 Routed |HfA - setting, if Routing Grid or Freferred Directions
are zet to Auto. Multiple-core proceszzors are

? Route? |H/h  + | 10 Routeld (HfA - SmpeELad

3 Route3 |Ffa = [ 11 Routell [H/a = Effort |High -

4 Routed |Hf& = |12 RoutelZ N/ - huto grid selection

5 RouteS [H/A ¥ |13 Routeld |N/A =+ | FBouting Grid m w3l

B Routef [H/A = | 14 Routeld [H/a = - Verdens, wAth Workowtor
Maxi b f 1 thread 2=

T RouteT |HfA | 15 RoutelS [H/a = |  ooomum TUMRED ob runming threads

g Routef [N/ | 16 Bottom -

I—/ \l—/ | Load. .. ||Save as. .. |

|Continue... | | Select | | Cancel |

Fig.27 Autorouter

6) Or the manually draw the wire by using “route” tool (-"' ). When use the “route” tool, the

wire attributes can be selected on the top of work area. E.g. The layer of the wire, the wire
bending type, wire width, via type etc.

H B (W6t ][]/ / /S £ Reins0 ~ [O7 g ooe « [HO ©  Disneter: st
Fig.28 wire attributes

If wire layout is needed to cancel, use the “ripup” tool ( A ). This operation does not cut

off the real connection (the air wire is keeping), just delete the wire lays on the board.
7) After the layout design, run the DRC to check if any error exists in the design.

C. The special points about project PCB design.
According the steps which are introduced in section 6.2, the PCB design can be almost finished.
There are still some different points which are needed to explanation.

a) About layer

Different PCB elements are on the different layer. In EAGLE, layer can be setting in menu
“View”->"layer setting”. In this window, all the possible layers are shown with different
identify colors. The layer visible or add/delete operation can be done here.
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Fig.29 Layer setting

Following tables are some commonly used default layer.

Num. Name Description
1 top Top side of PCB. Most components and wires lay on this layer.
16 Bottom | Back side of PCB. Few components and wires lay on this layer.
17 Pads Solder Pads hole
18 Vias Conductor holes though the PCB
21 tPlace | Silk screen, top side, For the short text
22 bPlace | Silk screen, back side, For the short text
25 tNames | Text of component names at top side
26 bNames | Text of component names at back side
27 tValues | Text of component values at top side
28 bValues | Text of component names at back side

b) General DRC setting

These DRC settings are used for all there module (power supply, DVM, main)

The board dick is 1mm, both side has copper layer with 18um dick. These values should be
filled in to “DRC” ->"layer” panel.
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™7 DRC (default %)

| File | Layers | Clearance I Distance I Sizes Restring Shapes Supply I Masks= | Ni=e |

1 Hr Copper Is

1 0.018mm
1mm
16 0. 015mm

Total: 1.036mm

16

Setup  (1%16)

Fig.30 Project PCB layer setting

Some of the components need lay on the edge of the board in the project. The
“Copper/Dimension” in the “DRC”->"Distance” panel should be set to Omil.

| File I Layers I Clearance | Distance | Sizes I Restring I
Copper/Dimenzion Omil
Irill/Hole Bm1l

.

Fig.31 Distance setting

Other DRC rule can use the default value.

4.3 The final PCB design and production board
With the above steps and rules, the final design is shown following:
A. Power module
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Fig.32 PCB of power module

B. DVM module
When install the components, the DVM and 2 buttons should be installed at back side of the

board.

=
=
o
o
O
o
-

1N 4142
|
01
POWER_IMF PROBE_INF

5
~ HoLOF LIGHTE

=

Fig.33 PCB of DVM module

C. Main board
The main board contains RF part (left small part) and DC analog part (right large part). The wide

short line and a lot of via holes are used in RF part. Ground (copper-pour area) between two
parts are connected with 0 Ohm resistor. In real board, several 0 Ohm resistors are used.

Wlllllga
prerreryd |
i SO

VIIIII.«?

Fig.34 PCB line schematic
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D. The production board
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5. System test

5.1 The introduction of test environment.
The main test devices are following:
® Pulse signal generator
Rigol DG1022 2 Channel 20MHz.
The pulse signal: 5Vpp with 95% duty cycle.
The inverse synchronous pulse signal will be feed to main board.

000,0%

Fig.37 Pulse signal generator

® RF signal generator

Rohde & Schwarz 100kHz-2160MkHz

The RF signal 300MHz

Power output: -30dBm to 15dBm. The output power can be read directly on the panel.

Fig.38 RF signal generator

® Oscilloscope

24



Fig.39 Agilent Oscilloscope

Agilnent MSOX3054A 500MHz

® RF Amplifier
Expand the test power rang to 40dBm

‘ N\

or LIV IOO

Rk 9696 E0EI0400

AR ’“A

Fig.40 RF Amplifier

® 40dB attenuator
Input protection for the oscilloscope.

® The full system
The 3 modules are assembled into a complete system
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Fig.41 The full system

5.2 The Line loss (Pioss) measuring.
Connect the RF signal generator to the Oscilloscope.
Record the output power value on the RF generator panel and the voltage value shown on the

oscilloscope.

Calculate the power value on the oscilloscope side.
Compare the difference of two power value get the line loss.

Pulse Gen

RF Gen

Oscilloscope

Line

Fig.42 connection of line loss measuring

The table of measuring is shown as following:

Input from Oscilloscope .
RF Gen line loss
(dBm)
(dBm) Voltage (V) Power (dBm)
15.000 3.000 13.522 1.478
14.500 2.800 12.923 1.577
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14.000 2.700 12.607 1.393
13.500 2.600 12.279 1.221
13.000 2.400 11.584 1.416
12.500 2.300 11.214 1.286
12.000 2.200 10.828 1.172
11.500 2.100 10.424 1.076
11.000 2.000 10.000 1.000
10.500 1.900 9.554 0.946
10.000 1.800 9.085 0.915
9.500 1.700 8.588 0.912
9.000 1.600 8.062 0.938
8.500 1.500 7.501 0.999
8.000 1.400 6.902 1.098
7.500 1.300 6.258 1.242
7.000 1.200 5.563 1.437
6.500 1.150 5.193 1.307
6.000 1.100 4.807 1.193
5.500 1.050 4.403 1.097
5.000 0.990 3.892 1.108
4.500 0.940 3.442 1.058
4.000 0.890 2.967 1.033
3.500 0.840 2.465 1.035
3.000 0.790 1.932 1.068
2.500 0.750 1.481 1.019
2.000 0.710 1.005 0.995
1.500 0.670 0.501 0.999
1.000 0.630 -0.034 1.034
0.500 0.600 -0.458 0.958
0.000 0.570 -0.903 0.903
Avg: 1.126
The voltage values read from oscilloscope are peak to peak value.
Thus the power calculation formula is following:
Power in dbm = 10 - log((ﬁ);'%), with R = 50Q (14)
The line loss should be:
Line loss (difference) = Value of RF Generator — Value of Oscilloscope (15)

The measuring result of the line loss Pjoss is about 1.1dBm.
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5.3 The determination of the real AP.
The AP is the only uncertain value in the formula (6). In order to determine AP, the voltage value
of TP1 and TP2 should be measured.

TP2 TP1
| : | Pulse Gen D / fffl

0 |:|./ 4
O O

RF Gen Line

Fig.43 connection of AP measuring

With TP1, the output power Pm and AP can be calculated. Due to the measurement error, the
AP is not a constant value.

Input
Input P TP1 / mV (AC rms) Avg P AP
with

dbm mV dBm dBm
loss 1 2 3 4 5

15| 13.9(1.250 | 1.080 | 1.150 | 1.170 | 1.270 | 1.184 | -45.523 | -59.423
14| 129(1.160 | 1.020 | 1.090 | 1.100 | 1.200 | 1.114 | -46.052 | -58.952
13| 11.9(1.080 | 0.980 | 1.000 | 1.030 | 1.130 | 1.044 | -46.616 | -58.516
12| 10.9(1.020 | 0.935 | 0.950 | 0.960 | 1.090 | 0.991 | -47.068 | -57.968
11 9.9 [ 0.990 | 0.890 | 0.900 | 0.925 | 1.020 | 0.945 | -47.481 | -57.381
10 8.9 (0.970 | 0.835 | 0.860 | 0.900 | 0.980 | 0.909 | -47.818 | -56.718
7.9 ({0.930 | 0.815 | 0.820 | 0.865 | 0.950 | 0.876 | -48.140 | -56.040
6.9 |1 0.900 | 0.795 | 0.800 | 0.845 | 0.930 | 0.854 | -48.361 | -55.261
5.910.870 | 0.770 | 0.780 | 0.830 | 0.910 | 0.832 | -48.587 | -54.487
4.9 (0.850 | 0.750 | 0.760 | 0.820 | 0.900 | 0.816 | -48.756 | -53.656
3.910.810 | 0.730 | 0.700 | 0.800 | 0.890 | 0.786 | -49.081 | -52.981

Vo (Y| |

The voltage values read from oscilloscope are ac rms value.
Thus the power calculation formula is following:

2
Power in dbm = 10 - log(%), with R =50Q (16)

With TP2 and formula (3), a reference output power P, can be calculated.
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VP AP dBm P2 P, dBm

dBm Vv

-45.523 -59.423 1.210 -39.6
-46.052 -58.952 1.190 -40.4
-46.616 -58.516 1.150 -42
-47.068 -57.968 1.130 -42.8
-47.481 -57.381 1.110 -43.6
-47.818 -56.718 1.090 -44.4
-48.140 -56.040 1.060 -45.6
-48.361 -55.261 1.030 -46.8
-48.587 -54.487 1.010 -47.6
-48.756 -53.656 0.980 -48.8
-49.081 -52.981 0.960 -49.6

Compare Pm and Py, find the closest values of Pmand P.. Then AP can be chosen.
The selected AP is considered to be the constant attenuator coefficient.

The measuring result of the real AP is about 53.7dBm.

5.4 The determination of the initial voltage at TP3.
With the formula (6), the initial TP3 can be determined.

TP2 = 0.2V (when no input, output TP2 is about 0.2V.)
Uo = 0.2V, Pp =-80dBm (From data sheet)

AP = 53.7dBm
0.2V — 0.2V + 0.025 7= (~80dBm) + 0.025 7= d . 53.7dBm
TP3 =
0. 025dB
= —26.3dBm (17)

This initial TP3 value can be used as a calibration base value.
On the board, the real TP3 is measured in voltage. When calibrate the system, the TP3 should
be -0.0263V.

5.5 The testing of rang from 0dBm to 15dBm.
After the setting of the initial TP3 value, the system can be test.

Directly connect the RF generator to the board with feeding the pulse signal to control the
sampling. Record and compare the input and output power.
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Pulse Gen

o [

LCD

RF Gen

Line

Fig.44 connection of testing of 0dBm to 15dBm

The measuring data list as follow:

. RF input Power .
RF input . Difference
dBm after Line show on dBm
dBm LCD dBm

15 13.9 13.9 0
14 12.9 12.9 0
13 11.9 11.9 0
12 10.9 10.9 0
11 9.9 9.8 -0.1
10 8.9 8.9 0
9 7.9 7.8 -0.1
8 6.9 6.8 -0.1
7 5.9 5.8 -0.1
6 4.9 4.8 -0.1
5 3.9 3.8 -0.1
4 2.9 2.9 0
3 1.9 1.9 0
2 0.9 1 0.1
1 -0.1 -0.4 -0.3
0 -1.1 -0.4 0.7

The output example show as follow:
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Fig.45 some results example

5.6 The testing of 12dBm to 42dBm with RF power amplifier.
Connect to the RF amplifier, the power rang 12dBm to 42dBm can be test.

[ 1] =
Pulse Gen D D
O O
| 11 11 ]
RF Gen
I L1 L1
L ! RF Amplifier
Line —

Fig.46 connection of testing of 12dBm to 42dBm
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The measuring data list as follow:

Output Output Power
RF input | with 40dB Power | show on | Difference
dBm attenuator | +40dB LCD dBm
ACrms mV dBm dBm
3 257.50 41.23 41.80 0.57
2 255.50 41.16 42.10 0.94
1 249.70 40.96 42.00 1.04
0 241.20 40.66 42.20 1.54
-1 228.40 40.18 41.80 1.62
-2 210.90 39.49 40.90 1.41
-3 190.30 38.60 40.10 1.50
-4 170.90 37.67 38.80 1.13
-5 151.50 36.62 37.60 0.98
-6 134.50 35.58 36.40 0.82
-7 126.00 35.02 35.60 0.58
-8 106.50 33.56 33.80 0.24
-9 93.50 32.43 32.80 0.37
-10 83.80 31.48 31.70 0.22
-11 74.50 30.45 30.60 0.15
-12 66.00 29.40 29.70 0.30
-13 59.30 28.47 28.70 0.23
-14 51.90 27.31 27.80 0.49
-15 47.80 26.60 26.90 0.30
-16 42.90 25.66 25.90 0.24
-17 38.30 24.67 25.00 0.33
-18 34.70 23.82 23.90 0.08
-19 30.80 22.78 23.00 0.22
-20 27.80 21.89 22.00 0.11
-21 24.90 20.93 21.00 0.07
-22 22.30 19.98 20.00 0.02
-23 19.80 18.94 19.00 0.06
-24 17.80 18.02 18.20 0.18
-25 16.10 17.15 17.20 0.05
-26 14.30 16.12 16.30 0.18
-27 12.60 15.02 15.40 0.38
-28 11.20 13.99 14.40 0.41
-29 9.90 12.92 13.50 0.58
-30 9.00 12.10 12.40 0.30
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The output example show as follow:

Fig.47 some results example

6. Conclusion and Discussion

After test, the system can operate under the expected conditions and give a relatively accurate,
linear measuring results in rang 0dBm to 40dBm.

Some points in system may need to discuss or improve.

1. System outputs 0 dBm, when there is no input.

The DVM module cannot show other symbol or characters to represent a meaning “no output”.
The 0 dBm is small enough to be a start point of the measure range.

2. Inthe 12dBm to 42dBm, the max measure error in the high power.
The problem may be caused by the RF amplifier. The power restrict in peak of wave form and
the result is not linear.
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3. The full 1kW input is not test because limitation of the laboratory conditions.
May could be some new problem in full power test.
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